"hello world"
article in Tech linux-unix-and-friends

Fedora / Centos / Redhat - a review of sorts.

func - Fedora Unified Network Controller, Func provides a two-way authenticated system for generically doing whatever you like. Written in Python.
fabric/fabric - Simple, Pythonic remote execution and deployment. SSH for deployment and sysadmin tasks.

CentOS 5

www.centos.org - The Community ENTerprise Operating System - main site.

CentOS 5 and Asterisk 1.4.x installation - voip-info.org

Should you receive an error about "TypeError: unsubscriptable object" when doing "yum update". Try using the following:
yum clean all

Setup Python 2.5, mod_wsgi, and Django 1.0 on CentOS 5 (cPanel) | Perplexed Labs
Fedora / CentOS / RHEL Linux change default desktop or display manager
I'm not sure why, but pear does not respect the php.ini for the whole system when it comes to memory limits. When trying to install some new pecl packages I got an error like 'Fatal error: Allowed memory size of 8388608 bytes exhausted'. To fix this, first you try changing the system php.ini. But that doesn't work. Then I tried setting the php.ini setting for pear and pecl. Still a no go. Then I found agile approach | HOWTO: Install PECL APC Cache on CentOS (without XAMPP), which detailed the way! Inside '/usr/share/pear/pearcmd.php' add the following to the beginning '@ini_set('memory_limit', '16M');'
tech: xdebug on centos
I decided to create a sep. page for MyDNS.
MyDNS - mysql based dns server., it runs great on CentOS.
The Perfect Server - CentOS 5.2 - Page 6 | HowtoForge - Linux Howtos and Tutorials - Apache2 With PHP & Ruby. 'yum install httpd-devel ruby ruby-devel', then details building mod_ruby.


Fedora Pastebin - where you want to go for output discussion on #fedora.
Welcome — Fedora Unity Spins - download pre-updated ISO livecds...
Getting started with virtualization - FedoraProject
autopsy.liveprojects.info - contains a project called c-section for making livecds/liveusb/etc.
Dracut - FedoraProject - Dracut is an initramfs infrastructure.
Linux Loadable Kernel Module HOWTO
jonEbird » 64bit Google Chrome with Flash on Fedora

LiveCD and LiveUSB goodness

Live USB - Wikipedia, the free encyclopedia
liveusb-creator - Trac - linux and windows tool to create liveusb disks! So very cool.
UNetbootin - Homepage and Downloads - linux and windows tool to create liveusb disks of even other distros besides Fedora...
Update kernel with syslinux (LiveUSB) - FedoraForum.org
liveusb keeps the boot config in /mnt/live/syslinux/syslinux.cfg, which is also where you'll find the kernel and initrd image too.
Features/BetterStartup - FedoraProject

Highpoint RocketRAID 1742 in Fedora 12

I bought this RAID card and wanted to use it in Fedora 12. HighPoint hasn't published the drivers for Fedora 12. So I decided to build them myself with the open source drivers found on the following website
HighPoint-Support-Bios + Driver - includes docs and rr1742 driver code.
I decided to create a liveusb drive to compile the kernel module for the RocketRAID 1742. I quickly created a liveusb using liveusb-creator but the first attempt failed because using 'yum install kernel-header' pulled kernel's headers that didn't match with the currently running kernel version.
yum install gcc kernel-devel-`uname -r` kernel-header-`uname -r` wget
# check website for latest!!!
wget http://www.support-highpoint-tech.com/Main/rr1740/Linux/opensrc/rr174x-linux-src-v2.4-091009-1434.tar.gz
tar xfvz rr174x-linux-src-v2.4-091009-1434.tar.gz
cd rr174x-linux-src-v2.4/product/rr1740pm/linux/
make install;
# make install, puts the rr174x.ko in:
# /lib/modules/`uname -r`/kernel/drivers/scsi/rr174x/rr174x.ko
mkdir /mnt/newinstall; mount /dev/sdc1 /mnt/newinstall
cd /mnt/newinstall;mkdir tmp;cd tmp;
zcat ../initramfs- | cpio -idv
cp -R /lib/modules/ lib/modules/
find . -print | cpio -H newc -o | gzip -9 > ../initrd-test.img
The following I used to make sure that the new driver showed up in the initrd image I created.
mkdir tmp; cd tmp;
cp /mnt/live/syslinux/initrd0.img initrd0.img.gz 
gunzip initrd0.img.gz;
cpio -idv < initrd0.img
(for i in `find . | grep "\.ko$"`; do basename $i | sed 's/.ko//' ; done )| sort

Autoload module on boot

Edit /etc/sysconfig/kernel to add a line 'INITRD_MODULES=yourmodname'

yum automatic updates

CentOS 5.2 Yum Automatic Updates « The Monkey Represents Sharing - yum install yum-cron, chkconfig --levels 2345 yum-cron

Remove i386 from a x86_64

To ensure you don't have any non-64 bit packages add "exclude = *.i?86" to your "/etc/yum.conf".
Then to remove the non-64bit packages which were already installed try running "yum remove *.i?86".

RPM package sources

RPM Fusion - RPM Fusion
Fedora Package Database
AdditionalResources/Repositories/RPMForge - CentOS Wiki - why do we have to add priority support and edit all the .repo files...anyways the nvidia-x11-drv.x86_64 is on rpmforge now.
ELRepo : HomePage - rpms for hardware stuff like capture cards,etc.

Fedora upgrades

Upgrading Fedora can be pretty easy if you use the "preupgrade" script. Give the following a try, I've used it to hop from Fedora 7 to Fedora 9! (maybe future upgrades go better)
How to use PreUpgrade - FedoraProject
Upgrading Fedora using yum - FedoraProject
yum update
yum install preupgrade
preupgrade OR preupgrade-cli

LVM Logical Volume Manager and other things related

Resizing Default LVM Partitions and Moving /boot - Mine the Harvest
Enterprise Volume Management System
Logical Volume Manager
lvchange -a y /dev/logicalvol/lv_root
lvchange -a n /dev/logicalvol/lv_root

Fedora 8

I can't believe how fast Fedora moves. Just a month ago I was working on Fedora 7. I'm interested to see how the install/upgrade goes from 7 to 8. Cool stuff.

To install from the console of a LiveCD, run the command "liveinst".
How To Upgrade Your Desktop From Fedora 7 To Fedora 8 | HowtoForge - Linux Howtos and Tutorials
Fedora 8 Installation Guide
Fedora 8 Tips & Tricks
Installing MyDNS And The MyDNSConfig Control Panel On Fedora 8 | HowtoForge - Linux Howtos and Tutorials
Fedora 8 Server Setup: LAMP, Email, DNS, FTP, ISPConfig (a.k.a. The Perfect Server) | HowtoForge - Linux Howtos and Tutorials

Fedora 7

I've decided to give Fedora Core another go. Last time I installed a Fedora Core it was at 2. Was pretty good but I found it to be a moving target. Upgrades were not seemless.

Fedora Core 7 was nice and easy to install. However, when up and running I didn't see a mouse cursor. However, I could left click and see context menus. I turned on the option to highlight the cursor using the CTRL key...and searched the web.

I found that it was an issue with the hardware cursor. So I had to add
Option "HWCursor" "off"
to the Device section in /etc/X11/xorg.conf.

So I'm trying the binary drivers on livna.org.
To install, it is really easy, download and install: http://rpm.livna.org/livna-release-7.rpm
Once that is installed, you can do a:
yum install kmod-nvidia
then configure it using:
Then reboot

Its working. Yeah!

Remixing Fedora 7
Fedora apt and yum repositories
DAG: RPM packages for Red Hat, RHEL, CentOS and Fedora

The Unofficial Fedora FAQ


Amarok is a new program I'm playing with. However, from some reason it doesn't include mp3 support out of the box. To enable mp3 in Amarok, using the following yum command:
yum install amarok-extras-nonfree
info found from: Amarok - Fedora Solved.

If you haven't already, checkout the Personal Fedora 7 Installation Guide, it has all sorts of information on how to setup samba shares and install nice packages. As always, its nice to review the services that get installed with a distro. Services in Fedora 7

I again used my doc from the last fedora setup for NTP...NTP - A little information on using NTP on fedora core.

Using Xen and virtualization tools in Fedora 7
Set Up OpenLDAP On Fedora 7 | HowtoForge - Linux Howtos and Tutorials


Vncserver Setup â?? Fedora Solved
Set up the VNC Server in Fedora
FedoraNEWS.ORG - HOWTO setup Freenx on Fedora

LSB - Linux Base Standard

Linux Standard Base (LSB) | The Linux Foundation

DST update for linux

It shouldn't be a problem if you update your OS....but sometimes ya need to keep running, ya know?! It isn't hard to do, just get the timezone data and source from nih.gov and overwrite your zoneinfo.
#check if you need update..
zdump -v EST5EDT | grep 2007
cd somewhereprivate;
wget 'ftp://elsie.nci.nih.gov/pub/tz*.tar.gz'
tar xfvz *.tar.gz
zic -d . northamerica
cp EST5EDT /usr/share/zoneinfo/
cp EST5EDT /etc/localtime
cp Indianapolis /usr/share/zoneinfo/America/Indianapolis
#check if you update worked.
zdump -v EST5EDT | grep 2007
Sources for Time Zone and Daylight Saving Time Data
Created: 2007-06-09 14:21:21 Modified: 2013-10-19 16:08:41
/root sections/
>peach custard pie
>random tech

moon and stars

My brain

Visible Dave Project

$$e = \sum_{n=0}^\infty \frac{1}{n!}$$ satis dictum.